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uitas Macmanias atras, ensinamos a

criacao de icones para o Mac OS que

atualmente chamamos de “cldssico”.
Na época, ainda estdvamos sob o impacto do
sistema 8.5 e seus novos icones em milhares de
cores. Mas eles ainda eram do mesmo tama-
nhinho mirrado de antes. Com os icones de
qualidade fotogrfica do Mac OS X; a filosofia e
a técnica iconografica mudaram. Algumas coi-
sas ficaram mais simples e outras, mais compli-
cadas. Estes s30 0s novos pontos que o icono-
plasta sério deve considerar:

Icones “clissicos”, desenhados pixel a pixel 2
mao, funcionam no Mac OS X, mas nio ficam
com boa aparéncia. Em vez do charmoso serri-
lhado, eles borram de forma meio desagradavel
quando ampliados.

Um icone criado especificamente para o
Mac OS X raramente fica inteligivel no Mac OS
classico. Especialmente os de aparéncia foto-
realista, que nio tém as linhas de contorno
caracteristicas dos icones “cldssicos”. Uma boa
sugestao ¢ cuidar para que sua imagem original
tenha um bom contraste interno, a fim de
reduzir essa deficiéncia.

Tem gente que teima em reclamar que os
novos icones do Mac OS X sio grandoes de-
mais, mas a real é que vocé raramente ird ve-
los no seu tamanho maximo. O Finder e o

Fique ligado

Iconoplasta - Quem faz icones. Néo con-
fundir com “iconoclasta”, que é quem des-
tr6i simbolos ou desmascara mitos.
Interpolacao - Recalcular os pixels de uma
imagem para um novo tamanho. O Mac 0S X
interpola em tempo real os icones de
128x128 pixels (Thumbnail) para qualquer
tamanho necessario no Dock e no Finder.

0 Mac OS classico usa trés dimensoes fixas:
32x32 pixels (Large), 16x16 (Small) e,
muito raramente, 16x12 (Mini). O tamanho
48x48 era usado somente no antigo Mac
0S X Server (Rhapsody).

Resource - No caso dos icones, € a dupla
desenho/mascara de cada um dos tamanhos
basicos dos icones. Para um icone funcionar
no 0S X e também no sistema classico, bas-
ta que ele contenha os resources nos tama-
nhos Thumbnail, Small e Large.

Mascara - Informacdo adicional que define
o recorte do icone.

Canal alfa - Na edicdo de icones, &€ um canal
de imagem extra, usado para criar a mascara
do icone.
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Novos tempos exigem novas regras
Aprenda a fazer icones para o Mac 0S X

Dock podem mostrar os icones em qualquer
tamanho; o costume ¢ deixa-los nao muito
maiores que o que seria usual no Mac OS clds-
sico, 2 menos que sua resolucio de tela seja
muito alta. Fora isso, as janelas do Finder por
lista sempre mostram os icones em tamanhos
pequenos. Isso tem uma consequéncia impor-
tante para o design: o reconhecimento visual
do seu icone nao pode depender de detalhes
diminutos, que desaparecam em tamanhos
como 64x64 ou 48x48 pixels.

E possivel transformar uma fotografia em
icone com incrivel facilidade — muito mais ficil
que no Mac OS classico.

As mdscaras com transparéncia, que ja exis-
tiam a partir do Mac OS 8.5, ganharam novas
possibilidades de uso. Para ter uma idéia, basta
observar as transparéncias e sombras no icone
do Sherlock do Mac OS X. Coisa fina.

O fato de os novos icones serem grandes e
foto-realisticos forca-nos a usar um editor de
imagens para obter melhores resultados com
designs originais. O passo-a-passo a seguir ilus-
tra a técnica bdsica para converter uma foto.

A imagem final a exportar para o icone serd

sempre na propor¢ao quadrada, mesmo que a
parte visivel (ndo recortada) do icone nio o
seja. Por isso, torne seu canvas de imagem
quadrado jd de inicio. V4 para Image » Canvas
Size e deixe a largura e a altura com a mesma
dimensio em pixels, seja qual for.
A imagem em edicio ndo precisa ter 128 pixels
de lado. Na verdade, € até bom que seja maior
que isso, a fim de facilitar a correcio de peque-
nos “gatos” em imagens complexas. Enfim,
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pode ser qualquer tamanho, exceto um muito
proximo a 128x128, para evitar perda de niti-
dez ao reinterpolar para o tamanho final.
Menor que 128x128 ¢ que nao pode.

Para o nosso exemplo, preferi facilitar a vida
programando as opcoes da ferramenta de Crop
do Photoshop para cortar a foto do Steve Jobs
ja para a dimensao final de 128x128.
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Se nio houver nada a fazer para melhorar a
foto, ¢ hora de gerar a méscara. Ela é um canal
alfa que vocé pode criar de diversas maneiras.
No exemplo, decidi eliminar o fundo preto
atrds do Steve. Transformei a foto em layer,
duplo-clicando no nome Background na palete
Layers e dando OK. A seguir, selecionei o fun-
do com a varinha magica, inverti a selecio
(Select » Inverse ou (@8)(Shift)(1)) e criei o canal
de recorte clicando no segundo mini-icone no
pé da palete Layers (o que tem um quadrado
com uma selecao redonda dentro).
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Que software usar?

Com o ResEdit ndo da para fazer icones para o Mac OS X, porque ele estacionou no tempo e ndo reconhece
como imagens os resources de icones grandes do OS X. Entdo, é necessario adotar algum editor especializado.
Eis as melhores opcdes atualmente disponiveis. Pegue os sharewares no site www. versiontracker.com

Shareware, US$ 15

Roda somente no Mac OS clissico, mas
gera icones compativeis com 0 OS X. E
um hibrido de editor de icones com
“Photoshop”. Nio, ele nao tem filtros e
layers. E que o autor reconheceu que

Vem de graca com o CD Developer Tools do Mac 0S X X 3 dann e todo iconoplasta profica usa Photoshop e
Programa “espartano” da Apple para montar e salvar ico- T por isso deu ao Iconographer uma inter-
nes. Ndo tem nenhuma ferramenta de edicio de imagem, atsin | o _ . face similar, com os mesmos atalhos de
mas € o Unico que importa diretamente arquivos de e ] teclado para ferramentas e menus.

Photoshop, com a mascara salva no canal alfa e tudo. Isso
faz muita diferenca na hora de gerar uma
baciada de icones novos de uma s6 vez.
Ha uma coisa meio “monga” na interface:
a0 importar, 0 programa mostra somente
o resource menorzinho (16x106) e é pre- —
ciso arrasta-lo para enxergar os demais.

Shareware, US$ 30 ;/
S6 para OS X. Meu atual -
favorito; é o mais sim- %
ples e bonito, com uma =

interface genuinamente Aqua que faz o
programa da Apple passar vexame. Na ver-
dade, nao é um editor, mas sim um mon-
tador de icones, feito para ser coadjuvan-
te de um editor de imagens. Para criar um
icone rapido e rasteiro, arraste para ele
qualquer imagem JPEG, TIFF ou GIF e
depois arraste o icone maior para as ban-
dejas a0 lado e abaixo para criar as mas-
caras e as versoes menores. Feito isso, €
s0 salvar. Mais pratico, impossivel.
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Mascara especial para a imagem, se hou-
ver, deve ser importada de um arquivo a
parte; ¢ claro que, se o programa sou-
besse importar diretamente de um arqui-
vo de Phososhop com canal alfa, seria per-
feito. Ele nio cria os resources de icones
de 16 e 32 cores, nem os de 48x48 e
12x12 pixels, o que de toda forma so faria
diferenca em Macs muito antigos.

A aba X-Ray View dd acesso a lista de
todos os resources criados.

L

p— Infelizmente, ele nao importa arquivos do
. Photoshop. E preciso arrastar diretamente
a imagem do Photoshop para o campo
correspondente no Iconographer (por
alguma razao absurda, o Cut-e-Paste nio
funciona). Idem para a mascara. O lado
bom € que a janela Members oferece uma
vista detalhada e bem explicada de todos
os resources, bastando arrasta-los de uma
para outra para criar as diversas versoes.
Mas se vocé quiser qualidade absoluta, é
melhor trazer os resources jd no tamanho
certo, porque a interpolagdo usada pelo
Iconographer nio ¢ tio boa quanto as
disponiveis no Photoshop. As ferramentas
de pintura dao para o gasto na tarefa meio
fora de moda de retocar as versoes me-
nores para que fiquem com aparéncia
decente no sistema cldssico.
Um recurso exclusivo

desse programa é que :
ele também sabe editar | ";
icones de Windows e
pode converté-los entre
os dois sistemas.

Barin Eicns (Thumbnail 12-bit icsal

Shareware, US$ 25
Esse ¢ um programa tradicional para o Mac OS 9 que foi “carbonizado”
para rodar também no Mac OS X. Sua origem como programa para “pen-
tear” pixels é denotada pelas paletes de pintura, que ficam meio sem uti-
lidade no OS X. Sua apresentacio nao-convencional exibe a mdscara e o
desenho do icone como
variantes da mesma jane-
la e assinala os pixels
transparentes um a um.
Mais facil por um lado,
mais dificil pelo outro.
Falta corrigir um bug: o
programa dd Quit imedi- =
atamente 20 tentar-se =5
arrastar desenhos deum =
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um gesto corriqueiro
nos outros editores.
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Abrindo a palete Channels, voc¢ verd um
novo canal em branco, o “Layer 0 Mask”. Nele,
o0 que ¢ visivel na imagem aparece como bran-
co, € o invisivel como preto. E o contririo de
como funciona a mascara de um icone, onde o
preto € visivel e o branco invisivel; mas a 16gica
¢ a mesma. Esse canal ndo tem cor, ou seja, é
em grayscale (escala de cinza).

Se vocé selecionar na palete Channels todos
0s canais juntos, a imagem aparecera recortada
sobre vermelho para demonstrar a transparén-
cia. Vocé pode alterar a
mdscara nesse modo e
enxergar em tempo real
as modificacoes. No
exemplo, acrescentei um
fade suave a camisa do
Steve, pintando cuida-
dosamente um degradé
sobre a mdscara.
Desligando todos os
canais menos o Mask, é
possivel entender como
isso se traduz no canal.

Seu icone estd pronto para exportar. Salve-o
no formato PSD e copie o layer e a mdscara
para o seu editor de icones, lembrando que
serd necessario inverter a mascara (@)(1)) para
que ela funcione corretamente.

0 método para transformar fotos em icones é
mais simples que o método para desenhos
vetoriais (Illustrator, FreeHand). Se vocé sus-
peita que a técnica acima € insuficiente para
gerar as complicadas mascaras dos ja famosos
icones de pictogramas da Macmania, tem razio.
O processo envolve mais manipulacio.

Ao importar (“rasterizar”) um desenho veto-
rial, ele ja vem como um layer flutuante. Se o
seu Photoshop for da versio 6.0, dé Image »
Trim para limitar o canvas a borda exata da
imagem. Sendo, dé um Crop manual rente a
imagem, sem interpolar. Em seguida, use o
Canvas Size para deixar a dimensao menor
igual 2 maior, obtendo assim o formato quadra-
do para a imagem.

Selecione a méscara do layer (€ s6 clicar
com @) no nome do layer na palete Layers).
Salve isso como um canal alfa (menu Select »

Save Selection, ou entao crie um canal novo na
palete Channels e dé Select » Inverse). Esse
canal alfa ja € o recorte do icone.

Crie um novo layer (clique no icone de do-
cumento no pé da palete Layers) e, ainda na
palete, arraste esse layer para baixo do outro.

Esta etapa nao ¢ realmente necessdria, mas
evita que o contorno do icone fique com
“rebarbas” sobre o desktop e o Dock.

Usando o pincel e o conta-gotas, pinte o layer
de trds com uma continuagcdo das cores que
aparecem ao longo das beiradas do desenho,
“esticando-0” para fora de seu recorte natural.
No nosso exemplo, d4 na mesma preencher
toda a drea ao redor da bomba de preto, ji que
os contornos do desenho sio pretos e fecha-
dos. Essa ¢ a situacio mais comum.
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Nos icones mostrados no box a direita, porém,
hi descontinuidades no contorno; repare no
cuidado em sempre estender esses trechos da
imagem para além da drea mascarada.

Junte os dois layers com o comando Layer »
Merge Visible ()(Shif|E)). Pronto: agora vocé
tem também a imagem do icone pronta.

Para criar efeitos de transparéncia dentro do
desenho, selecione a parte desejada da figura e
altere o seu tom de preto para cinza na mis-
cara. Para criar sombras, o processo € 0 opos-
to: pinte na drea branca da mdscara fora do
desenho. Por exemplo, adicionando uma drea
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Desenho x mascara

Um pixel preto na mascara corresponde a um
pixel 100% opaco no icone, e um branco a um
100% transparente. Os tons intermediarios de
cinza na mascara sao proporcionais aos varios
graus de transparéncia no icone. Vocé tem que
planejar a mascara junto com a parte visivel do
icone. Os icones abaixo aparecem repartidos em
contetido (imagem) e silhueta (mascara).

Mascara

&

Imagem
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cinzenta difusa a direita da bomba, criei uma
sombra para ela. Novamente, ligando na palete
Channels todos os canais juntos, é possivel ter
uma idéia do efeito enquanto est sendo edita-
do. Nao va misturar os pixels: a drea de sombra
no desenho fica “chapada” na cor desejada
(usualmente preta) e a transicio de tom da pe-
numbra ¢ criada inteiramente no canal alfa.

O icone estd pronto para exportar, bastando
inverter a mdscara.

Gostem ou nao os “da antiga” que desenhavam
pequeninas obras de arte pixel a pixel (eu fui
um deles), a técnica mudou. Mas agora hd cam-
po ainda mais vasto para a criatividade. Erra
quem acha que o virtuosismo morreu e que,
para fazer um icone para o OS X, basta dar um
“Save As” em uma foto qualquer. Entrei com
confianca no negocio: criei uma pagina de ico-
nes no meu site e botei o link no Iconfac-
tory.com, o maior site de icones da Web. IV}

MARIO AV
E iconoplasta e também iconoclasta.
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