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seu email

Aprenda a criar filtros de email

a edicdo passada, vimos como fazer

para configurar os programas Claris

Emailer, Eudora, Communicator e o
Outlook Express para enviar e receber emails a
partir de qualquer computador conectado a
Internet. Beleza. Desta vez, veremos outras
manhas e macetes para trabalhar com um
recurso muito util: os filtros de mensagem.
Como o proprio nome ja sugere, eles fazem
uma triagem nas mensagens recebidas, a partir
de parimetros predeterminados, podendo
separa-las em diferentes pastas, imprimi-las,
abri-las e outras acoes, tudo automaticamente.
Assim, se vocé sempre recebe mensagem
daquele mala-de-plantao-cibernético, por exem-
plo, é possivel determinar que, um email dessa
pessoa seja enviado diretamente para a lixeira.
Ou entao, se vocé assina alguma lista de discus-
soes, pode criar um filtro que armazena todas
as mensagens dessa lista em uma pasta especifi-
ca. Com isso, vocé perde menos tempo organi-
zando todos os seus emails.
Soa interessante? Entdo, vamos ver como criar
esses filtros nesses clientes de email.

O modus operandi dos filtros de email é basi-
camente 0 mesmo em todos 0s programas, mas
¢ claro que cada um tem suas nuances. De
qualquer modo, os conceitos basicos sio os
mesmos para todos. Para facilitar as coisas, va-
mos primeiro entender como funciona a logis-
tica do processo (ver também o quadro “Ana-
tomia de um filtro”).

Todo filtro precisa incluir pelo menos um crité-
rio que diga a0 programa “o corpo da mensa-
gem contém o termo tal” ou “o remetente nio

¢ editor@macmania.com”. Se o aplicativo encon-
trar alguma mensagem que obedeca esse crité-
rio, ele ird executar a acao predeterminada
pelo usudrio.

Em resumo, o que um filtro faz ¢ dizer algo do
tipo: “se o endereco de email X constar como
o remetente (sender) da mensagem, faca o
favor de colocar a mensagem na pasta Y.
Porém, muitas vezes, ¢ preciso somar dois ou
mais critérios para tornar um filtro eficiente.
Assim, € possivel acrescentar ao exemplo acima
mais um comando como, digamos, “Se o crité-
rio anterior for falso, veja se o assunto (sub-
ject) da mensagem comeca com tal palavra e,
se verdadeiro, execute as acoes determinadas;
caso o critério nao seja valido, esquega tudo e
nao aplique a agio”.

Deu para entender? T4 complicado? Entéo,
vamos tentar um exemplo mais pratico.
Imaginemos que voc¢ assine uma newsletter
online e queira que todas as mensagens relati-
vas sejam automaticamente guardadas na pasta
chamada Noticias. Em qualquer cliente de
email que tiver a op¢ao de filtrar mensagens
havera sempre um campo em branco, onde, no
caso, voce vai escrever o endereco de email do
remetente da newsletter (ex.: news@oftheworld.
com). Haverd também mais dois menus. Um
deles permite selecionar em que parte da men-
sagem o enderego devera ser procurado.
Assim, selecione o item Sender (ou From,
dependendo do aplicativo) no primeiro menu.
No outro menu vocé deve selecionar a opgao
“Is”, para especificar que o remetente “f
news@oftheworldcom. O proximo passo € definir
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o que sera feito com a mensagem que obede-
cer a esse critério. Assim devera haver um
botao ou um campo chamado Actions ou algo
similar, que permitird escolher a pasta onde a
mensagem serd acolhida. Em geral, os progra-
mas de email permitem selecionar mais agoes,
como repassar a mensagem para outro endere-
co, marcar como lida, rodar um AppleScript ou
imprimir 2 mensagem, entre outras coisas.
Feito isso, salve as opgoes e seu filtro esta
pronto. Agora vamos ver como funciona esse
processo em cada um dos casos.

No Claris Emailer, os filtros chamam-se Mail
Actions. Vi até o menu Setup » Mail Actions.
Na janela Mail Actions List, clique no botio New
para criar um filtro.

Mail Action Entry: Macmania

Hail action name ; [Masmania

Criteria:

Field: [ Reply-ta w | [_contains - rnagnet.cor)

Actions:
File the message in " Masmania ﬁ
Define Actions.
R cnasis TR stepmat soin irorets aremat e

Nela vocé encontrard uma janela com as
seguintes opgoes:

= Mail action name: O nome do filtro.

= Criteria: No menu da esquerda vocé define
em que parte da mensagem sera feita a procura
(From, To, CC, Reply To etc.). Ja no menu da
direita sao definidas as varidveis (¢, no €,
comeca com etc.). O campo em branco é onde
voce poderd escrever a palavra-chave (ou ende-
reco de email) do filtro.

= More/Fewer Choices: Se quiser adicionar novos
critérios ao filtro, clique em More Choices e
entio clique no botao com o simbolo “+”.
Defina o filtro e clique OK. Uma nova linha serd
acrescentada. Para deleta-la, clique no icone da
lixeira ou do lapis para editar o critério. Na
coluna Test (testar), aparecera a sintaxe do cri-
tério (ex.: From Is “steve.jobs@apple.com”). A
segunda coluna, If True, ¢ onde vocé diz o que
o Emailer fard se o critério for verdadeiro. Vocé
pode selecionar no menu as opgoes Apply
actions (aplicar agoes), Don't apply actions (nio
aplicar acoes) e Go to next line (vd para a proxi-
ma linha). A coluna If False diz o que fazer caso
o critério seja falso, oferecendo o mesmo menu
da coluna If True. Sempre selecione Don't apply
actions na ultima linha, senao o filtro vai ser
executado independentemente do critério.
Tudo isso pode parecer meio complicado, mas



esse recurso do Emailer oferece a oportunida-
de de criar filtros bem precisos. Assim, vocé
pode fazer com que o filtro s6 execute uma
funcao quando varios critérios forem verdadei-
ros, por exemplo.

Mail Action Entry: Newsletter

Mail action name: [Mewsletter

Criteria:

# Test | If True | If False -
= From Contans "Techwet pply aotions o toretine (=)

T From Contains "@amazon.com ™ Apply actions [®] Bo to next line =
4 From Contains “ConDY apply actions [ o tonext ne ()|
S From Contains "pbemb@midiguy.com®  Apply setions Bon't apply actions([¥] [+

#Actions

File the message in *Hewslatter ﬁ

Define Actions...
&=

[~ Stop mail actions if eriteria are met

X Enabled

= Define Actions: Abre a janela onde vocé pode
selecionar as agoes do filtro. Na janela Action
Entry, hd uma série de opgoes. Para definir a
pasta onde as mensagens serdo armazenadas,
selecione o quadradinho ao lado de File Mes-
sage e, entdo, clique no menu ao lado para sele-
cionar a pasta desejada. Caso vocé ainda nio
tenha criado uma pasta, selecione a op¢ao
Select a Folder, clique em New Folder e dé um
nome para ela. Vocé também pode definir va-
rias outras agoes. Feito isso, clique em Save.
Vocé vera o resumo das agoes no campo Actions.
= Enabled: Selecione o quadradinho para habili-
tar o filtro (isso também pode ser feito na jane-
la Mail Actions List).

= Stop mail actions if criteria are met: Essa é
uma fun¢io importante para quem possui
varios filtros diferentes. Na janela Mail Actions
List vocé pode alterar a ordem dos filtros arras-
tando-os para a posicio desejada. Assim, vocé
pode determinar quais serdo os filtros domi-
nantes. Ao habilitar essa funcio, se as agoes de
determinado filtro forem aplicadas, todos os
outros que se seguem na lista serdo ignorados.

Os filtros de email sao chamados de Mail
Rules no Outlook Express 4.5. Para criar um,
selecione a opcio de menu Tools » Mail Rules.
Na janela que surge, clique em New Rule. Vocé
encontrard as seguintes opgoes:

= Rule name: nome do filtro (regra, no caso). Ao
lado desse campo, vocé pode selecionar se o
filtro sera aplicado as mensagens que sao rece-

=————— Define MailRule
Rule nsme [ #pply to incoming  [] Apply to outgoing
- Criteria
From # || Contains 2 |[pisda
M4 [subject % [(Boez not contain | 2 [4stoife ]
O [Frem % J[Contains B!
Execute actions if (all erfterisaremet | 3]
- hations
Action 1: [ Move message =] [orans =)
Astion 2: [Forward %] [mnigro@mstrix com.br
Astion 3¢ [ Play sound %] [Indige ]
Action 4: [ Save attachments %) [estination..._]
[ Stop spplying rules to this message
=

bidas (Apply to incoming) ou as que sao envia-
das (Apply to outgoing).

= Criteria: No menu da esquerda vocé define
em qual cabegalho da mensagem sera feita a
procura. Ja no menu da direita vocé define as
varidveis. O campo em branco é onde vocé
podera escrever a palavra-chave (ou enderego
de email) do filtro. Vocé ainda pode criar mais
dois critérios em cada filtro, habilitando os
quadradinhos no lado esquerdo.

= Execute actions if: Nesse menu é possivel
determinar se as acoes serdo executadas se
qualquer critério for obedecido (any criteria are
met) ou apenas se todos os critérios forem ver-
dadeiros (all criteria are met).

= Actions: No Outlook Express 4.5 vocé pode
combinar até cinco acoes diferentes. Para
mover a mensagem para uma pasta especifica,
selecione Move message e, entdo, a pasta de
destino no menu que surge ao lado. Se vocé
quiser uma pasta nova, terd que fechar a janela
e crid-la a partir do menu File » New » Folder,
ou pressionar (Shift) @N).

[[] =———— MailRules =
+ +

Ne?gule Dele%Rule Edf%ule Meowe Up Mowve Dovwn

¥ Piadaz =

¥ Sewo |

%" Matahari

¥ Newsletter

¥ Coisas

¥ FEI

%" Rio Centro

%" Barbie

¥ Segredos
[~
[+
Z

= Stop applying rules to this message: Quando
se criam varios filtros na janela Mail Rules, vocé
pode alterar a ordem deles. Assim vocé pode
determinar quais serdo os filtros, dominantes.
Ao habilitar essa funcio, se as agoes de deter-
minado filtro forem aplicadas, todos os outros
que se seguem na lista serdo ignorados. Para
alterar a ordem dos filtros, selecione um e cli-
que em Move Up ou Move Down na janela Mail
Rules (para deletar um filtro, clique em Delete
Rule e, para editd-lo, clique em Edit Rule).

Para criar um filtro no Messenger do Commu-
nicator, selecione Edit » Message Filters e clique
no botao New. No campo ao lado aparece a
ordem dos filtros (se vocé criar mais do que
um) e um quadradinho para habilitar ou desa-
bilita-los. Para alterar a ordem ¢é s6 clicar e
arrastar um filtro para cima ou para baixo.
Assim, vocé pode determinar quais sdo os mais
importantes.

No campo Description, vocé pode escrever uma




[0 =————Messagefilles ———H &
== = [[Firters on server_ |
Order [Hame [Enabled [E

1 Fladas M |~
2 Mewslatter (%)
% Trabakhe [
Description
[ Keep log
Yiew Log

~# Filter Action
If an incaming message

() Matches all of the following

sender - I contains = I list@users com

(@) Matches any one of the following

[(subjest | & [[contains =] [mPs ]
Then [ Mave to folder 2 [Loaie 2| [Mew Faider. ]

descri¢do de cada um dos filtros. Logo abaixo
voce vé a drea Filter Action, onde € possivel
criar até dois critérios para cada filtro (clique
no botdo More para acrescentar ou Fewer para
reduzir os critérios). Porém, ¢ possivel determi-
nar apenas uma agao per capita. Para que o fil-
tro mova uma mensagem para uma pasta, sele-
cione Move to folder no Gltimo menu a esquer-
da e selecione a pasta no menu ao lado. Para
criar uma nova pasta, clique em New Folder. Na
janela que surge vocé pode nomear a pasta e
determinar sua localizacio.

Depois de definir os critérios, selecione a
opcao Matches all the following se quiser que a

Anatomia de um filtro
Um filtro de email é composto de critérios e acoes. Os critérios estabelecem condicoes que
acionam o filtro. S6 quando tais condicoes sdo obedecidas é que as acoes sdo executadas.
Qualquer programa de email que tenba a capacidade de criar filtros apresenta trés pardme-
tros para cada critério, apresentados na forma de dois menus e um campo em branco. Veja
no diagrama como funciona um filtro.

cabecalho

acao seja executada apenas se todos os crité-
rios forem obedecidos. J4 opcio Matches any
one the following aplica o filtro se qualquer um
dos critérios for verdadeiro.

O Eudora ¢é, provavelmente, o cliente de email
que possibilita criar mais facilmente filtros,
oferecendo varios modos de executar essa
tarefa. O jeito mais rapido de fazer isso € sele-
cionar alguma mensagem a partir da qual vocé
deseja criar um filtro e selecionar o menu
Special » Make Filter. Uma janela semelhante a
esta deve aparecer:

Make Filter

Match:
[ Incarning [ Dutgaing [ Manual

| editar @ macmania.com.br |

@ From containg

() &ny Recipient contains [ mnigro@spo.matrixcom.br ||E|

() Subject contains [ Aplle mostra s G4

Action:

@) Transfer to nes mailbox | Heinar Maracy |

Thiz mailbox will be created in Mail Falder.

() Transfer to existing [ <<None Chosen>> ]

() Delete Message (transfer to Trash)

[ concel | [ Add Details | |[ createFilter ||

Na parte superior da janela, existem trés qua-
dradinhos onde vocé pode selecionar se o fil-
tro vai funcionar para as mensagens recebidas

nao aplicar acao
tentar de novo

=

Variavel

Aqui se escolhe uma variavel
de busca. Com isso, vocé pode
determinar que o filtro atue,
por exemplo, quando o reme-
tente é fulano, quando o corpo
da mensagem contém certa

Cabecalho

Aqui vocé escolhe em
qual parte do cabegalho
(header) de uma mensa-
gem serd feita a procura.
E possivel escolher entre:
=From ou Sender

(remetente) palavra e assim por diante.
= To (destinatario) As opgdes mais comuns Sao:
=(C (copia) = Contains (contém)

=Does Not Contain

(ndo contém)

uIs (&)

= Js Not (ndo é)

s Starts With (comeca com)
=Ends With (termina com)

= Subject (assunto)
=Reply-to (responder)
=Body (corpo do texto)
= Any Recipient (qualquer
destinatério)

= Any Header (qualquer
cabecalho)

Alguns programas ofere-
cem outras opcoes.

aplicar
acao

Palavra-chave
Aqui vocé es-
creve um en-
dereco ou pala-
vra-chave para
ser procurada
na mensagem.

Acdo

Depois de um ou mais critérios da
filtragem terem sido atendidos, o fil-
tro podera executar vérias agoes.

A mais comum é Move to Folder
(ou Transfer To), que serve para
enviar a mensagem para uma pasta
especifica. Em geral, vocé também
pode definir agbes como abrir a men-
sagem (Open), responder (Reply),
encaminhar (Forward), imprimir
(Print), rodar um AppleScript (Run
AppleScript) e diversas outras, que
variam de um aplicativo para outro.
= Se nenhum critério for atendido,
ndo executar nenhuma acao.

= Se 0 primeiro critério for falso,

ir para o segundo (se houver) e
tentar de novo.

(Incoming), enviadas (Outgoing) ou se o filtro
serd acionado manualmente (Manual).

Abaixo, aparece o contetdo de trés cabegalhos
do email previamente escolhido: o remetente
(From Contains), qualquer um dos destinatrios
(Any Recipient) e 0 assunto (Subject). Se quiser
que o filtro seja aplicado ao remetente discri-
minado, selecione From Contains.

Para determinar a agio, existem outras trés
opcoes:

= Transfer to new mailbox: Transfere as mensa-
gens para uma nova caixa postal (pasta), digi-
tando o nome no campo em branco.

= Transfer to existing: Armazena o email
automaticamente em uma pasta ja existente.
Clique em <<None Chosen>> e depois escolha a
caixa postal desejada na op¢ao Transfer da
barra de menu.

= Delete Message: Boa opgao para filtrar spam
ou aquelas pessoas malas que s6 mandam
email chato. Selecione esta op¢ao e a mensa-
gem ird direto para o lixo.

Clique em Create Filter para terminar.

A outra maneira de criar filtro no Eudora é ir
direto 20 menu Windows » Filters. Nessa janela
vocé poderd, na coluna a esquerda, escolher a
ordem de prioridade de seus filtros (caso vocé
tenha mais do que um), arrastando-os para
cima ou para baixo.

Para criar um novo filtro, clique no botiao New
(ou Remove para remover). Depois defina

os parametros do critério nos menus Header e
de variavel de busca, além do endereco ou
palavra-chave que ativara o filtro. Se vocé qui-
ser adicionar mais um critério ao filtro, clique
no menu onde esta escrito Ignore e selecione
uma das outras opgoes. O And determina que o
filtro deve obedecer a somatoria dos dois crité-
rios. O Or estabelece que qualquer uma das
duas condigoes pode ser aceita. E o Unless diz
que o primeiro critério deve funcionar a menos
que a segunda opcao seja verdadeira.

Por fim, é possivel selecionar até cinco agoes
para o filtro, como transferir para uma determi-
nada pasta, imprimir, responder ou encami-
nhar o email, mover os arquivos “atachados”,
entre outras coisas.

A conclusio nio pode ser outra: quem recebe
muitos emails ndo tem melhor alternativa para
organiza-los do que usar os filtros. Com eles,
vocé pode ir direto as que mais lhe interessam
e deixar as mensagens chatas ou sem importan-
cia para depois. Isso se algum filtro ja nio as
tiver colocado na lixeira. E més que vem tem
mais dicas sobre programas de email! (V3

MARCIO NIGRO
Esta tentando coar café com os filtros do Emailer.



